Email delay
Incident Report for OrangeQC
Resolved
This issue has been resolved and all mail is now being sent normally.
Posted Feb 01, 2024 - 12:54 CST
Identified
We are currently working with our email service provider to investigate an issue that is delaying all OrangeQC email. We will post another update as soon as we learn more.
Posted Feb 01, 2024 - 12:16 CST
This incident affected: Management Portal.