The issue has been identified and a fix is being implemented.
Posted Jun 12, 2025 - 14:07 CDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Jun 12, 2025 - 14:07 CDT
Investigating
Our upstream provider, Cloudflare, is having DNS issues that has resulted in our homepage being unavailable. More info can be found at https://www.cloudflarestatus.com.